Xperia SX をいじっていたら起動しなくなった

シェアする

  • このエントリーをはてなブックマークに追加
  • 35

sony_xperia_sx


バッテリー持ちを良くしようと思い、ついでにWi-Fiのスキャン間隔を延ばすためにBuild.propをいじっていたら

なんと!!

Xperia SXが起動しなくなってしまいました!(笑)

よくよく見るとBuild.propの中の数字の間にスペースが入っていて、
これが悪さをして起動時にフリーズを起こしていた様です。

ああ、これで安心。

そこを修正して、パーミッションも合わせて再起動。


・・・ん?

・・・・・・・・あああああああああああああああああああああああ!

変化無しです。
見事に逝ってしまわれた。


仕方なくシステムダンプを取って、初期化しようと思ったら・・・・

ん?ん?あれ??????

ない!!

System配下がごっそりいない・・・・・・!

なぜ!?wwwww


うーん、初めにBuild.propを書き換えたときにパーミッションを間違ったのか
何なのか分かりませんが、大体その辺のタイミングで消えてしまったようです・・・・


復元しようにも、こんな時にバックアップも取って無いと言う。


そこで思い出したのがSX用154ROM

これは最近あったアップデートを適応したSX用のカスタムロムで
インストールしたアプリや設定はそのままROMを導入出来るという何ともありがたい代物です。

このROMをインストールしたら、あら不思議。

見事に復活しました。

が、データは保持できているのですが、system自体をいじっていたので
その部分の構築をし直さなければと、せっせと作業して、
一通り環境復元が完了。

さて、では再起動を。

「連絡先が終了しました」

起動は出来たものの、今度は電話帳がエラーを吐くようになりました。
電話帳を差し替えても、パーミッション変えても、キャッシュを削除しても直らない!!


仕方なく、再度SX用154ROMから復旧。

「連絡先が終了しました」

おい!なんでだ!System領域を初期化しただろ?なぜ直らない。

と何度かの初期化のタイミングでエラーが出なくなり、まともに動くようになりました。

何がダメだったのか分かりませんが、まぁ直ったという事で万々歳です。

そう。根本的な解決には至っておりません(笑)…いや笑えないか。

でもまぁ、何はともあれ

「System配下をいじるときは些細なことでもバックアップは必要」

という事をまざまざを見せつけられた一件でした。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

コメント

  1. ひか より:

    自分のxperia tab z もbuild.propをいじくってたら起動しなくなってしまってます。。。

    • 鑑人 より:

      ひか さん

      こんにちは。コメントありがとうございます。

      build.prop をいじって起動しなくなったのなら、
      まずは build.prop を正常のものに書き直して見ればいいのではないかと思われます。

      該当バージョンのFTFからSystemDumpを取って、中に入っているbuild.propをZ Tabに書き戻すと起動するのではないかとは思いますが…。
      それでも起動しない場合はSystemだけを焼き直して見ればいいのではないでしょうか。

      SONYロゴすら起動しないのであれば完全な文鎮化となりますので、ハード的に修正の必要が出てきます。
      そうなるとバックパネルを剥がしたりといろいろと面倒なのであきらめるしかないとか思います。
      文鎮化は同世代のZ等でもあるみたいです。